Konuyu Oyla:
  • Toplam: 0 Oy - Ortalama: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Buildozer Yardım!!
#1
Kivy proje mi buildozer ile apk haline getirmeye çalışırken  hata alıyorum yardımcı olabilirmisiniz?
Hata çıktısı link
Ara
Cevapla
#2
(22-02-2018, Saat: 18:30)Compagni Nickli Kullanıcıdan Alıntı:  Kivy proje mi buildozer ile apk haline getirmeye çalışırken  hata alıyorum yardımcı olabilirmisiniz?
Hata çıktısı link

dosya yolunda Türkçe karakter olduğu için.

Masaüstü/MeslekTestiApp

Olmadı pc dilini ingilizce yap dene..
Ara
Cevapla
#3
Teşekkürler işe yaradı ama bu sefer de
Böyle bir hata alıyorum:
[WARNING]: ERROR: /home/deniz/.buildozer/android/platform/apache-ant-1.9.4/bin/ant failed!
Ara
Cevapla
#4
Log'un tamaminı atarmısın..
Ara
Cevapla
#5
[WARNING]: ERROR: /home/deniz/.buildozer/android/platform/apache-ant-1.9.4/bin/ant failed!
# Command failed: /usr/bin/python -m pythonforandroid.toolchain apk --debug --bootstrap=sdl2 --dist_name metapp --name 'Meslek Egilim Testi' --version 0.1 --package org.test.metapp --android_api 19 --minsdk 9 --private /home/deniz/MeslekTestiApp/.buildozer/android/app --orientation portrait --window --copy-libs --arch armeabi-v7a --color=always --storage-dir=/home/deniz/MeslekTestiApp/.buildozer/android/platform/build
#
# Buildozer failed to execute the last command
# The error might be hidden in the log above this error
# Please read the full log, and search for it before
# raising an issue with buildozer itself.
# In case of a bug report, please add a full log with log_level = 2
Ara
Cevapla
#6
Warning'den öncesi yok mu?
Ara
Cevapla
#7
BUILD FAILED
/home/deniz/.buildozer/android/platform/android-sdk-20/tools/ant/build.xml:720: The following error occurred while executing this line:
/home/deniz/.buildozer/android/platform/android-sdk-20/tools/ant/build.xml:734: Compile failed; see the compiler error output for details.

Total time: 1 second


STDERR:


[INFO]: STDOUT (last 20 lines of 72):
[echo] ----------
[echo] Handling Resources...
[aapt] Generating resource IDs...
[aapt] (skipping file '.gitkeep' due to ANDROID_AAPT_IGNORE pattern '.*')
[echo] ----------
[echo] Handling BuildConfig class...
[buildconfig] Generating BuildConfig class.

-pre-compile:

-compile:
[javac] Compiling 26 source files to /home/deniz/MeslekTestiApp/.buildozer/android/platform/build/dists/metapp/bin/classes
[javac] error: Source option 1.5 is no longer supported. Use 1.6 or later.
[javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.

BUILD FAILED
/home/deniz/.buildozer/android/platform/android-sdk-20/tools/ant/build.xml:720: The following error occurred while executing this line:
/home/deniz/.buildozer/android/platform/android-sdk-20/tools/ant/build.xml:734: Compile failed; see the compiler error output for details.

Total time: 1 second
[INFO]: STDERR:

[INFO]: COMMAND:
cd /home/deniz/MeslekTestiApp/.buildozer/android/platform/build/dists/metapp && /home/deniz/.buildozer/android/platform/apache-ant-1.9.4/bin/ant debug

[WARNING]: ERROR: /home/deniz/.buildozer/android/platform/apache-ant-1.9.4/bin/ant failed!
# Command failed: /usr/bin/python -m pythonforandroid.toolchain apk --debug --bootstrap=sdl2 --dist_name metapp --name 'Meslek Egilim Testi' --version 0.1 --package org.test.metapp --android_api 19 --minsdk 9 --private /home/deniz/MeslekTestiApp/.buildozer/android/app --orientation portrait --window --copy-libs --arch armeabi-v7a --color=always --storage-dir=/home/deniz/MeslekTestiApp/.buildozer/android/platform/build
#
# Buildozer failed to execute the last command
# The error might be hidden in the log above this error
# Please read the full log, and search for it before
# raising an issue with buildozer itself.
# In case of a bug report, please add a full log with log_level = 2
Ara
Cevapla
#8
Scriptin ile ilgili biraz ipucu verebilirmisin?

Mesela uygulamanda jnius kullandın mı?

Ve sakıncası yoksa buildozer.spech'i atarmısın?
Ara
Cevapla
#9
Projede kivy haricinde kütüphane kullanmadım
buildozer.spec dosyası
Ara
Cevapla
#10
İşletim sisteminiz nedir bilmiyorum ama belkide vm kullanıyorsunuz ama biraz araştırma sonucunda sorunun jdk versiyonundan kaynaklandıği soÿleniyor, önerilen çözümler jdk 7 veya 8 e güncellemek. İkisinide deniyebilirsin..

Ayrıntılı anlatmamakla bereaber bunun için şu komutu kullanın demişler ve ardından jdk 7 veya 8 i seçip yükleme yapın demişler..

PHP Kod:
sudo update-alternatives --config java 

Diğer bir öneri ise temiz yeniden bir paketleme için şu komutlar

PHP Kod:
buildozer android clean 
PHP Kod:
buildozer distclean 
Ara
Cevapla

{lang: 'en'}


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Son Yorum
Exclamation Kivy Label yardım Compagni 4 2,145 10-02-2018, Saat: 23:58
Son Yorum: gecemor

Hızlı Menü:


Konuyu Okuyanlar: 1 Ziyaretçi
Change Theme